kb405338

When you try to open the Adobe Photoshop Elements 6 Organizer on Windows Vista, the application closes during its startup process and returns this error:

You have an older version of QuickTime that may be incompatible with Microsoft Windows Vista. Please upgrade to the latest version of QuickTime to avoid seeing the following error dialog when launching Photoshop Elements in the future.

Leave a Reply